Abstract

WARM (Water Accounting Rice Model, Confalonieri et al., 2005a, 2007; Acutis et al., 2006; Confalonieri, 2006) is a user-friendly, simplified daily time step model for simulation of growth and development of paddy rice crops. The model accounts for all the main processes which characterize this peculiar system in a balanced way. The software has a modular structure, thus including independently developed components formalizing the knowledge in specific fields of rice and/or modelling research. A suite of tools is supplied to support analysis of various type such as model evaluation (Bellocchi et al., 2006), sensitivity/uncertainty analysis (Confalonieri et al., 2006), and parameter calibration (Acutis and Confalonieri, 2006).

The model is meant to serve as an analytic tool to study rice development and productivity under alternative conditions. It simulates the occurrence of phenology events, leaf evolution and biomass growth. The model is written in Visual Basic.


Crop development

Crop development is based on the thermal time accumulated between a base temperature (Tb, ºC) and a cutoff temperature (Tc, ºC), optionally modulated by a photoperiodic factor.

Thermal time
Base and cutoff temperatures are different for the periods sowing-emergence and emergence-harvest. Photoperiod-based correction can be activated for the period emergence-flowering. The degree-days are converted into a decimal code (assuming values from 0.00 to 2.00) to standardize development stages (phenophases are not explicitly determined).
Decimal codes are obtained, respectively for the period emergence-flowering and flowering-physiological maturity, with the following equations:

- Emergence-flowering

- Flowering-physiological maturity

where DVS is development stage code, GDDcum (°C-days) are cumulated growing degree days, GDDem (°C-days) are growing degree days required to complete emergence, GDDflo (°C-days) are growing degree days required to complete flowering, and GDDmat (°C-days) are growing degree days required to complete physiological maturity. According to the decimal code (the same as for the SUCROS-derived models, van Ittersum et al., 2003), 0.00 corresponds to emergence, 1.00 to flowering, 2.00 to physiological maturity. Listed below are decimal codes for the main stages:

  • Emergence: 0.00

  • Beginning of tillering: 0.25

  • Mid tillering: 0.35

  • Panicle initiation: 0.60

  • Heading: 0.90

  • Flowering: 1.00

  • Grain filling: 1.40

  • Physiological maturity: 2.00

  • Harvest: >2.00

Photoperiod
The response to photo-period is approximated by a linear relation of day length (DL, h), which fluctuates from 0 and 1, multiplicative of growing degree days accumulated in the course of crop development.

For long-day varieties:

For short-day varieties:

where DLins (h) is day length for insensitivity, DLif (h) is day length to inhibit flowering. The photo-periodic factor fluctuates between 0 and 1 within the two critical day-length thresholds.

The shape of fphoto is given in the exemplary graph below for both short-day (blue line) and long-day (fuchsia line) varieties:


Crop growth

Aboveground biomass rate (AGBd, kg m-2 d-1) is calculated on a daily time step as:

where Rad (MJ m-2 d-1) is daily global solar radiation, [image] is the fraction of PAR intercepted by the canopy, k is light extinction coefficient, LAI (m2 m-2) is leaf area index, RUEact (g MJ-1) is actual photosynthetically active radiation (PAR=0.5·Rad, MJ m-2 d-1) use efficiency, which varies according to irradiance level, development, diseases, nitrogen concentration and cold injuries. It is calculated as follows:

RUEmax (kg MJ-1) is the RUE value (crop parameter) not limited by water, nutrients, pest, diseases, senescence, excess of radiation, temperature, damages. Tlim, Rad_F and DVS_F are unitless factors in the range 0 (maximum stress) – 1 (no limitation) accounting for temperature limitations, saturation of the enzymatic chains, and senescence phenomena, respectively.

Tlim is temperature-limitation factor, calculated according to Yan and Hunt (1999):

where T (ºC) is the mean daily air temperature, Tc (ºC) is the ceiling air temperature at which crop growth ceases, To (ºC) is the optimal air temperature at which the maximum rate of development occurs, Tb (ºC) is the base air temperature for crop growth, C is a shape factor set equal to 1.8 to allow the beta-function to approximately cross linear progression between Tb and To at Tlim=0.5 (see figure below as an example with Tb=0, To=30, Tc=40).

The factors accounting for saturation of the enzymatic chains involved with photosynthesis (Rad_F) and for the effect of senescence (DVS_F) are calculated using empirical functions derived, respectively, by Choudhury (2001) and Campbell et al. (2001):

where DVS is the development stage code.

Algorithms to account for other factors on RUE are under development.


Biomass partitioning

Daily aboveground biomass (AGBd, kg m-2 d-1) (see Crop growth) is partitioned to leaves, panicles and stems.

AGBd is partitioned to leaves using a parabolic function which assumes the maximum value (input parameter; RipL0) at emergence and zero at flowering:

where DVS is development stage code (see Crop development), LeavesAGBd (kg m-2 day-1) is the AGBd partitioned to leaves. This approach to partitioning (based on a single parameter, RipL0) is a compromise between the SUCROS approach (van Keulen et al., 1982), considered difficult to be reasonably parameterized for large scale simulations and other simple, empirical approaches (e.g. the CropSyst approach, Stöckle et al., 2003).

AGBd partitioning to panicles starts at the panicle initiation stage (PI) and it is assumed as maximum (all the accumulated biomass is partitioned to panicles) at the beginning of the ripening phase. Like for the allocation of AGBd to leaves, a parabolic function is used:

where PanicleAGBd (kg m-2 day-1) is the AGBd partitioned to panicles.

Stem biomass is derived by subtracting panicle and leaf biomasses to total above ground biomass.


Spikelet sterility

A daily factor accounting for spikelet sterility due to cold shocks during the period between panicle initiation and heading is calculated (see developmental stages in Crop development) as derived by the investigations of Kakizaki and Kido (1938) reported by Nishiyama (1995):

where Tthresh (°C) is the threshold temperature below which cold-induced sterility damages are caused, Th (°C) are the hourly temperatures, DVS11 is the DVS (see Crop development) of the 11th day before heading (DVS code = 0.56), g and d are variety-specific coefficients used to discriminate among varieties which are sensitive for few or many days around the 11th day before heading (midpoint of time elapsed from panicle initiation and heading).

The integral of factor SterilityF is a reduction factor of PanicleAGBd (see Biomass partitioning).


Meristematic apex height

The height of the meristematic apex is a key variable for many processes (including spikelet sterility). it allows get the correct temperature (at the meristematic apex height) from the TRIS micrometeorological model (Confalonieri et al., 2005b). TRIS allows the crop model to simulate crop growth, spikelet sterility, etc. taking into account floodwater effect on the vertical thermal profile.

Height of the plant meristematic apex (H, m) is given by:

where Hmax (cm) cultivar-specific maximum height input parameter, DVS is daily development stage decimal code, DVSPI is decimal code at panicle initiation.


Leaf area expansion

Leaf area index (LAI, m2 m-2) is computed multiplying the leaf biomass times a specific leaf area (SLA, m2 kg-1) variable according to the development stage:

where SLAtill (m2 kg-1) is the SLA at the end of the tillering stage and SLAini (m2 kg-1) is the SLA at emergence, DVS=35 is the development stage code for mid tillering.

Each day, leaf senescence is calculated by subtracting the dead LAI to the total LAI. The dead LAI is obtained by killing the LAI accumulated in the day in the past identified by subtracting the LeafLife (input parameter; °C-d) to the current DVS (a correspondence between DVS and days is maintained).


Diseases effect

This section is under development.


Control

Control dialog box contain information allowing the user to set specifications for a simulation to be run.

A name may be entered in the input field at the top of the dialog box to identify the simulation.

The initial and final dates (day of year) specify the period of the simulation. The simulation starts and stops on these dates. Therefore: 1) the initial date must be less than the final date, 2) the starting date should be before the planting date of the crop, 3) the ending date should be after the harvest date.

Two simulation options may be selected: soil dynamics and diseases.

Other options refer to leaf area index (LAI, m2 m-2) simulation. LAI calculated by WARM uses the internal routines for LAI simulation. The option Forcing LAI with NDVI-derived data allows the user using an NDVI estimate as an exogenous source of LAI data. This option requires specifying the date (day of year) when the LAI estimation was carried out, and the estiamed LAI value. A third option (Reinitialize and recalibrate WARM using remotely sensed LAI data) reinitializes some inputs of the model on the basis of available data for that simulation. The fourth option (Exogenous LAI data for each simulation day) allows using a set of daily LAI values, imported from an Excel file including two columns (one for day of year, the second for the LAI values). The fifth option (Exogenous LAI data periodically available) allows using a series of LAI values periodically available for the simulation, imported from an Excel file. Button LAI simulation performance Index computes statistics to compare WARM-simulated LAI values against those derived from forcing. It applies to the second, the forth and the fifth option.

The report options refer to the possibility to generate an Excel report file. The output variables available for reporting are listed and optionally selected.


Crop

The crop parameter editor consists of three sections, plus an informational description box. A set of default values is given.

Section Development parameters contains parameters for computation of crop development, according to one of three optional methods: temperature based, photoperiod based and base on both temperature and photoperiod. The base and maximum temperatures (ºC) for the computation of elapsed degree-days (GDD) must be specified for two phases: before and after emergence. The thermal time (degree days) required for each of the phenologic stages of development must be also specified for three phases: from sowing to emergence, from emergence to flowering, from flowering to maturity. DLC (critical day-length) and DLO (optimum day-length) are input parameters to calculate photo-period effects on physiological (thermal) time accumulation (see Crop development).They are required for the option accounting for photo-period effects. Development stage at harvest is a code (DVS, Crop development) determining the time left after physiological maturity (DVS=2) before harvest.

Section Growth parameters includes parameters defining the crop sensitivity to environmental conditions and required to compute crop growth, biomass partitioning, meristematic apex height, and leaf area expansion. Radiation use efficiency (g MJ-1) represents the aboveground biomass production per unit of light intercepted by the crop canopy. Extinction coefficient for solar radiation depends on the canopy structure and determines the ability of a canopy of a given leaf area index (see Leaf area expansion) to intercept solar radiation. Base, optimum and maximum air temperatures (ºC) for biomass accumulation (see Crop growth) are parameters of a beta function for computation of a temperature limitation factor. Leaf area index at emergence (m2 m-2), specific leaf area at emergence (m2 kg-1) and fraction of biomass partitioned to leaves at emergence are initial leaf area parameters for computation of leaf area expansion. Specific leaf area end tillering (m2 kg-1) is the value of specific leaf area at completion of tillering. Leaf life (ºCd) corresponds to the degree-days elapsed between the appearance and senescence of new green area index. Crop coefficient kc at full canopy represents the ratio of unstressed crop evapotranspiration to reference (short grass) evapotranspiration when the crop has developed a full canopy.
Maximum panicle height ()
Evapotranspiration crop coefficient (kc) at full canopy represents the ratio of unstressed crop evapotranspiration to reference (short grass) evapotranspiration when the crop has developed a full canopy.

Spikelets sterility-related parameters can be optionally activated. They include a sensitivity parameter (around 1; <1 for resistant cultivars, >1 for sensible cultivars), a threshold temperature for spikelet sterility, and a duration of the critical period out of two options (for many days, for a restricted period).


Management

WARM provides options for specifying water management (including irrigation) and chemical treatments. The management entry forms consist of two sections, one for each type of management, plus a common section.

A description of the simulation may be entered in the input field at the top of the dialog box (common section).

The location is specified here with the site latitude in degrees (common section).

The sowing date is set by the day of year (common section).

In the irrigation section, an irrigation strategy is selected out of two options: flooded, unflooded. Water level (cm) may be set to a fixed value if the fixed option is selected. Alternatively, the water level is dynamically computed which requires an initial level to be set. Water inflows and outflows are specified as water inputs and outputs. Each event (input or output) is characterized by a water amount (mm), supplied daily from an initial to a final date. The duration in hours of the input event is also specified. A function for simulating the effect of water in preventing spikelet sterility from cold shocks can be optionally activated (it works only with the fixed water level). Water level (cm) at pre-flowering should be specified.

In the chemical treatments section, options for simulation of blast (Pyricularia grisea (Cooke) Sacc.) attacks are provided. No treatment or, alternatively, a chemical treatment is applied (tricyclazole only in the current version). The schedule of treatments is specified by the day of year when the chemical treatment is applied.


Soil

Soil is divided in a number of layers, numbered from top (1) to bottom (up to 15), and soil properties referring to each layer are provided as input.

Soil layer thickness must be provided in meters.

The value of bulk density is expressed in grams of soil mass per cubic centimeter of soil volume.

The carbon matter content (%) and the water content at the beginning of the simulation are specified here.

Percent clay and sand are provided; percent silt is computed as a complement to 100%.

The soil water content at field capacity and at permanent wilting point (expressed as cubic meter of water per cubic meter of soil volume) are given to characterize the soil hydraulic properties, together with the soil hydraulic conductivity (mm h-1).

Other soil inputs are optional, and are estimated at the first simulation if missing. They are van Genuchten (1980) soil moisture parameters: soil water content at saturation (m3 m-3), residual soil water content (m3 m-3), a (cm-1) and n. The method HYPRES (Wösten et al., 1999) estimates the parameters of the van Genuchten retention function using silt (Si, %), clay (Cl, %), bulk density (BD, t m-3), organic matter (OM, %), and topsoil (qualitative variable in a binary form: 0, 1). The van Genuchten retention function is the following:

where ym (kPa) is the pressure corresponding at SWCact, SWCr (m3 m-3) is the residual water content, SWC0 (m3 m-3) is the water content at soil saturation, SWCact (m3 m-3) is the actual soil water content, a (kPa-1), m and n are empirical parameters.
The parameters are estimated using the following equations:

with SWCr=0.1.


Weather

Daily weather files are created and manipulated by Microsoft Excel spreadsheet (.xls). There must be one file for each year of interest. The weather Excel files have the following characteristics:

  • Each line represents one day of data

  • There must be either 365 (or 366 for leap year) lines

  • Depending on the format used, all column entries must be provided

  • Data for precipitation, maximum and minimum air temperature and global solar radiation must be inputted. Maximum ad minimum relative humidity can be missing and will be estimated at the first simulation.

  • The day of year number must be an integer

  • All other numbers may have integer or real number format

  • The file must be sorted by day of year

  • There must one variable in each column

The weather files may have one of the following formats depending on available data:

1. Day of year, precipitation (mm), maximum air temperature (ºC), minimum air temperature (ºC), global solar radiation at ground level (MJ m-2 d-1); i.e.
1 0 7.3 4.4 2
2 0 6 4 2.1
3 6 9.6 3 2.1
......................

2. Day of year, precipitation (mm), maximum air temperature (ºC), minimum air temperature (ºC), global solar radiation at ground level (MJ m-2 d-1), maximum air relative air humidity (%), minimum relative air humidity (%); i.e.
1 0 7.3 4.4 2 100 86
2 0 6 4 2.1 100 84
3 6 9.6 3 2.1 100 82
......................

Weather variables other than relative humidity are used to compute Priestley-Taylor evapotranspiration (Priestley and Taylor, 1972; Steiner et al., 1991). Humidity values are used for estimation of diseases effects.


Output

The outputs generated from a simulation run are graphically reported in the output form. The top graph include crop growth and development variables. The bottom graph displays weather variables, plus water level, desease and sterility outputs.


Evaluation

Graphical and numerical capabilities are given in the evaluation form. One-at-a-time variable is selected from a drop-down list and displayed graphically. The left-hand graph is a time course of the variable. Simulated versus observed graph is also produced, including data points, 1:1 line and least squares regression line. Numerical indices of model performance are computed using the dynamic link library for model evaluation IRENE_DLL (Fila et al., 2003, http://www.sipeaa.it/tools).


About

The current version of WARM was developed by the Joint Research Centre of the European Commission, Institute for the Protection and the Security of the Citizen, Agriculture and Fisheries Unit, MARS-STAT project, in cooperation with other institutions.

Development and programming: Roberto Confalonieri

Scientific cooperation: Marco Acutis, Luigi Mariani, Marinella Ridolfi, Marcello Donatelli, Gianni Bellocchi, Patrizia Trevisiol, Davide Gusberti, Gabriele Cola, Iacopo Cerrani, Anna Maria Picco, Stefano Bocchi, Davide Venanzio, Federico Spanna, Mirco Boschetti, Daniela Stroppiana

DISCLAIMER This software is made available free of charge to non profit users thorough the site http://mars.jrc.it/marsstat/WARM. The developing institutions cannot be held responsible for misuses of WARM. You will need to contact the authors if you intend to use WARM in profit related applications. Please interact with the WARM staff of developers for bugs or any other comment about WARM you may wish to make.


References

Acutis, M., and R. Confalonieri. 2006. Optimization algorithms for calibrating cropping systems simulation models. A case-study with simplex-derived methods integrated in the WARM simulation environment. Ital. J. Agrometeorol., 3:26-34.

Acutis, M., R. Confalonieri, G. Genovese, M. Donatelli, M. Ridolfi, L. Mariani, G. Bellocchi, P. Trevisiol, D. Gusberti, and D. Sacco. 2006. WARM: a new model for rice simulation. IX European Society for Agronomy Congress, 4-6 September, Warsaw, Poland, 259-260.

Bellocchi, G., R. Confalonieri, and M. Donatelli. 2006. Crop modelling and validation: integration of IRENE_DLL in the WARM environment. Ital. J. Agrometeorol., 3:35-39.

Campbell, C.S., Heilman, J.L., McInnes, K.J., Wilson, L.T., Medley, J.C., Wu, G., and D.R. Cobos. 2001. Seasonal variation in radiation use efficiency of irrigated rice. Agric. Forest Meteorol., 110:45-54.

Choudhury, B.J. 2001. Modeling radiation- and carbon-use efficiencies of maize, sorghum and rice. Agric. Forest Meteorol., 106:317-330.

Confalonieri, R. 2006. Preface to the special issue ("1st European meeting on WARM: a rice modelling experience"). Italian Journal of Agrometeorology, 3:5-7.

Confalonieri R., M. Acutis, G. Bellocchi, I. Cerrani, S. Tarantola, M. Donatelli, and G. Genovese. 2006. Exploratory sensitivity analysis of CropSyst, WARM and WOFOST: a case-study with rice biomass simulations. Italian Journal of Agrometeorology, 3:17-25.

Confalonieri, R., M. Acutis., M. Donatelli, G. Bellocchi, L. Mariani, M. Boschetti, D. Stroppiana, S. Bocchi, F. Vidotto, D. Sacco, C. Grignani, A. Ferrero, and G. Genovese. 2005a. WARM: a scientific group on rice modelling. Italian Journal of Agrometeorology, 2:54-60.

Confalonieri, R., M. Acutis, M. Donatelli, G. Genovese, L. Mariani, D. Gusberti, P. Trevisiol, M. Rodolfi, A.M. Picco, I. Cerrani, and G. Bellocchi. 2007. WARM: a new model for paddy rice simulations. p. 126-127. In Proc. of the 4th International Temperate Rice Conference, June 25-28, Novara, Italy.

Confalonieri, R., L. Mariani, and S. Bocchi. 2005b. Analysis and modelling of water and near water temperatures in flooded rice (Oryza sativa L.). Ecol. Modell., 183:269-280.

Fila, G., G. Bellocchi, M. Donatelli, and M. Acutis. 2003. IRENE_DLL: a class library for evaluating numerical estimates. Agron J., 95:1330-1333.

Kakizaki, Y., and M. Kido. 1938. Growth stages susceptible to low temperatures in grain ripening of rice plants. Agriculture and Horticulture, 13:59-62.

Nishiyama, I. 1995. Damage due to extreme temperatures. p. 769-800. In Matsuo, T., Kumazawa, K. , Ishii, R., Ishihara, K., Hirata, H. (Eds.), Science of the rice plant - Vol. 2. Physiology. Food and Agriculture Policy Research Center, Tokyo, Japan.

Priestley, C.H.B., and R.J. Taylor. 1972. On the assessment of surface heat flux and evaporation using large-scale parameters. Mon. Weather Rev., 100:81-82.

Steiner, J.L., T.A. Howell, and A.D. Schneider. 1991. Lysimetric evaluation of daily potential evapotranspiration models for grain sorghum. Agron. J., 83:240-247.

Stöckle C.O., Donatelli M., and R. Nelson. 2003. CropSyst, a cropping systems simulation model. Eur. J. Agron., 18:289-307.

Van Genuchten. 1980. A closed-form equation for predicting the hydraulic conductivity of unsaturated soil. Soil Sci. Sot. J., 44:892-898.

Van Ittersum, M.K., P.A. Leffelaar, H. van Keulen, M.J. Kropff, L. Bastiaans, and J. Goudriaan. 2003. On approaches and applications of the Wageningen crop models. Eur. J. Agron., 18:201-234.

Van Keulen, H., Penning de Vries, F.W.T., and E.M. Drees. 1982. A summary model for crop growth. p. 87-98 In Penning de Vries, F.W.T., Van Laar, H.H. (Eds.), Simulation of plant growth and crop production. Simulation Monographs. Pudoc, Wageningen, The Netherlands.

Wösten, J.H.M., A. Lilly, A. Nemes, and C. Le Bas. 1999. Development and use of a database of hydraulic properties of European soils. Geoderma 90:169-185.

Yan, W., and L.A. Hunt. 1999. An equation for modelling the temperature response of plants using only the cardinal temperatures. Ann. Bot., 84:607-614.